> Faqs > Problema en opencart composer/autoload_real.php failed to open stream

Problema en opencart composer/autoload_real.php failed to open stream

Hola buenas Noches he tenido ultimamente el siguiente Error en mi web:

Warning: require_once(/home/mac/public_html/vqmod/vqcache/composer/autoload_real.php): failed to open stream: No such file or directory in /home/mac/public_html/vqmod/vqcache/vq2-_home_mac_Macdata_storage_vendor_autoload.php on line 5

Fatal error: require_once(): Failed opening required '/home/mac/public_html/vqmod/vqcache/composer/autoload_real.php' (include_path='.:/opt/cpanel/ea-php73/root/usr/share/pear') in /home/mac/public_html/vqmod/vqcache/vq2-_home_mac_Macdata_storage_vendor_autoload.php on line 5

He tratado de ver el corregir el error en Opencart pero no pude

Quisera si son tan amables que me ayuden a solucionarlo

Respuestas

El problema parece que está resuelto en este post del forum de Opencart:

https://forum.opencart.com/viewtopic.php?t=219456

Básicamente te piden que borres la carpeta "vendor", que es donde están las dependencias de composer, para que se vuelvan a descargar.

Según apuntan hay que borrar toda la carpeta esta:

upload/system/storage/vendor 

Sin conocer opencart, pienso que es un poco raro donde está la carpeta vendor, porque realmente suele están en la raíz del proyecto. En todo caso, echa un vistazo y mira a ver dónde está esa carpeta. La puedes borrar sin miedo porque luego con composer se instalarán de nuevo todos los archivos de las dependencias del proyecto.

Luego te indican que hagas un comando:

composer update 

Con ese comando es con el que se vuelven a instalar las depedencias, y de paso se actualizan las que hayan recibido actualizaciones que se deban instalar.

Espero que se pueda solucionar de esta manera. Saludos!

Alberto
471 11 33 15