Webshims : HTML5 en tu navegador

  • Por
Librería JavaScript con la que añadir la última versión del lenguaje básico de la web en casi cualquier navegador.
27/04/2012 - Pese a la sorpresa que para muchos pueda causar la siguiente información, Internet Explorer 6 sigue siendo el quinto navegador más usado con una cuota de mercado cercana al 7%. Especialmente relevante se muestra el uso de este navegador en determinados ambitos empresariales pese a la llegada de las actualizaciones silenciosas.

El dato anterior nos sirve para introducir que el porcentaje de usuarios que a día de hoy siguen usando navegadores considerados como obsoletos o con falta de soporte para los últimos estandares y tecnologías es mucho más grande del que pensamos.

Para salvar la distancia que existe entre las posibilidades que ofrecen tecnologías como HTML5 normalmente acudimos a Polyfills con los que es posible dar funcionalidades estable de la última versión del lenguaje básico de la web (HTML5) a navegadores que no las soportan.

Fruto de lo anteriore nace Webshims, una librería Javascript que automatiza el proceso de carga de Polyfills mediante la deteción de capacidades de una navegador con Modernizr.

Soportado por IE6 y superior, Firefox 3.6 y superior, Safari 4 y superior, Chrome 16 y superior, opera 11.6 y superior gracias a Webshims vamos añadir a estos navegadores compatibilidad para renderizado, reproducción de audio y vídeo, canvas.....

Interesados pueden acceder a más información sobre las características, demos, código de ejemplo, y descarga de la última versión de Webshims pueden acceder a afarkas.github.com.